Anhang und XHTML mit Fehlern

Allgemeines zum XML-Format der eBilanz
Antworten
logoweb
Beiträge: 5
Registriert: Mi Sep 14, 2016 11:43 pm

Anhang und XHTML mit Fehlern

Beitrag von logoweb » Mi Sep 14, 2016 11:50 pm

Ich erhalte bei der Validierung die Meldung:
D:\Nagelshof\Software\eBilanz\ini\footnotes\nt.taxReport.htm: Invalid document structure
Linie: 2.
Die Datei nt.taxReport.htm sieht so aus:
<html>
<head>
<title>Anhang zum Jahresabschluss per 31. Dezember 2015</title>
</head>
<body>
<p><b>Anhang zum Jahresabschluss per 31. Dezember 2015</b></p>
<br/>

Ich habe auch bereits eine andere Fehlermedlung erhalten (Fehlerhafte Zeichen "U+00B6"). Im letzten Jahr hatte ich die Datei dann ganz ohne HTML-Code erstellt, das lief dann durch...

mhanft
Site Admin
Beiträge: 514
Registriert: Sa Apr 12, 2014 12:52 pm
Kontaktdaten:

Re: Anhang und XHTML mit Fehlern

Beitrag von mhanft » Do Sep 15, 2016 9:46 am

Hallo, rein optisch sieht das eigentlich ganz gut aus. Ich könnte mir höchstens vorstellen, dass die Datei evtl. in "UTF-8 mit BOM" (Byte-Order-Mark) abgespeichert wurde, dann gibts am Anfang ein (unsichtbares) Steuerzeichen, das da nicht hingehört. Auch das angemahnte Zeichen U+00B6 ist irgendein (unsichtbares) Steuerzeichen (Sie wollen sicher kein "Â" verwenden).

Evtl. können Sie Ihre Anhangsdatei ja mal auf solche unsichtbaren Steuerzeichen untersuchen (z.B. mit "Notepad++", Einstellen auf "Ansicht - Nicht druckbare Zeichen - Alle Zeichen anzeigen). Wenn unter "Codierung" einfach nur "UTF-8" angezeigt wird, müssen Sie das auf "UTF-8 ohne BOM" umstellen.

Mit dem Windows-eigenen Editor "Notepad" kann man die unsichtbaren Steuerzeichen leider nur erkennen, indem man mit den Cursortasten Zeichen für Zeichen "abfährt"; bei einem unsichtbaren Steuerzeichen bleibt der Cursor rein optisch an derselben Stelle stehen. Man kann es dann aber mit der Rücktaste löschen (und sieht auch dabei keinen optischen Effekt).

Ich hoffe, diese Tipps helfen Ihnen erst mal weiter...

logoweb
Beiträge: 5
Registriert: Mi Sep 14, 2016 11:43 pm

Re: Anhang und XHTML mit Fehlern

Beitrag von logoweb » Do Sep 15, 2016 9:15 pm

Danke für die schnelle Antwort. Ich schicke jetzt 'mal die komplette Datei als Anhang. Die Kodierung ist UTF-8 ohne BOM, dennoch kommen die angehängten Fehlermeldungen. Die HTM-Datei finden Sie (lässt sich nicht hochladen) hier: http://cdu-nagel.de/nt.taxReport.htm
Vielen Dank im Voraus.
Dateianhänge
Fehler.txt
(6.56 KiB) 764-mal heruntergeladen

mhanft
Site Admin
Beiträge: 514
Registriert: Sa Apr 12, 2014 12:52 pm
Kontaktdaten:

Re: Anhang und XHTML mit Fehlern

Beitrag von mhanft » Do Sep 15, 2016 9:38 pm

Ah, ok. Sie hatten vorhin nur den Anfang Ihres Anhangs gepostet, und dort waren überhaupt keine Umlaute drin, daher hatte ich angenommen, es wäre egal, ob der Rest in UTF-8 oder OEM850 oder ISO-8859 oder sonstwas wäre. Jetzt habe ich aber gesehen, dass im Rest des Anhangs Umlaute vorkommen - und die sind in UTF-8 codiert. Für ELSTER muss aber alles in ISO-8859 vorliegen! Also einfach umcodieren und dann sollte es gehen...

logoweb
Beiträge: 5
Registriert: Mi Sep 14, 2016 11:43 pm

Re: Anhang und XHTML mit Fehlern

Beitrag von logoweb » Do Sep 15, 2016 10:02 pm

Das Wort Größenklassen sieht dann so aus:
Größenklassen...
dennoch richtig?

logoweb
Beiträge: 5
Registriert: Mi Sep 14, 2016 11:43 pm

Re: Anhang und XHTML mit Fehlern

Beitrag von logoweb » Do Sep 15, 2016 10:17 pm

Ich habe jetzt anstelle von Notepad++ (das bei UTF => ISO wohl fehlerhaft arbeitet) die Onlinekonvertierung

http://www.motobit.com/util/charset-cod ... ersion.asp

genutzt, damit ging das ganze tadellos! eBilanz ist beim Finanzamt! Bitte ergänzen Sie Ihre Doku. ensprechend, denn dort ist nur von UTF die Rede.
Zuletzt geändert von logoweb am Do Sep 15, 2016 10:18 pm, insgesamt 1-mal geändert.

mhanft
Site Admin
Beiträge: 514
Registriert: Sa Apr 12, 2014 12:52 pm
Kontaktdaten:

Re: Anhang und XHTML mit Fehlern

Beitrag von mhanft » Do Sep 15, 2016 10:17 pm

Wie das bei Ihnen ausschaut, hängt natürlich davon ab, welche Anzeigeeinstellungen Sie verwenden...

Ich habe Ihre Datei mal in ISO-8859-1 konvertiert. Sie können Sie hier runterladen: http://www.myebilanz.de/temp/nt.taxReport.htm

Auch die Kontobezeichnungen in der CSV-Datei müssen in ISO-8859-1 enthalten sein. Mit UTF-8 kann ELSTER grundsätzlich nichts anfangen :)

mhanft
Site Admin
Beiträge: 514
Registriert: Sa Apr 12, 2014 12:52 pm
Kontaktdaten:

Re: Anhang und XHTML mit Fehlern

Beitrag von mhanft » Do Sep 15, 2016 10:24 pm

Hallo, da haben sich unsere Postings gekreuzt...
  • Ich habe Ihre Datei mit Notepad++ konvertiert - mit "Kodierung - Konvertiere zu ANSI" (bei den Umlauten ist "ANSI" ISO-8859-1-kompatibel).
  • Bei den CSV-Dateien steht in der Anleitung "Kontenbezeichnungen müssen im ISO-8859-1-Zeichensatz angegeben werden, kein UTF-8 etc., keine speziellen Sonderzeichen wie Gedankenstriche, graphische Zeichen o.ä., kein €-Symbol", bei den Fußnoten habe ich gar keinen Zeichensatz erwähnt - das werde ich noch nachholen. Haben Sie irgendwo eine Stelle gefunden, bei der ich UTF-8-Zeichen angebe/vorschreibe? Wo?

logoweb
Beiträge: 5
Registriert: Mi Sep 14, 2016 11:43 pm

Re: Anhang und XHTML mit Fehlern

Beitrag von logoweb » Fr Sep 16, 2016 12:27 am

Stimmt, das steht da gar nicht, sondern Sie haben es nur hier in Ihrer Antwort erwähnt. Ich danke Ihnen auf alle Fälle für Ihr tolles Tool, das eine große Hilfe ist, wenn man wie ich keine Lust hat, jährlich Geld für Fibu-Software-Updates auszugeben, die man gar nicht benötigt.

Antworten